Theme-D-Gnome

Requirements

You must have the following software installed to use Theme-D-Gnome:
  • Guile 2.2. Theme-D-Gnome versions before and including 0.7.3-1 use Guile 2.0. It should be possible to build the newer releases of Theme-D-Gnome for Guile 2.0, though.
  • Theme-D. Theme-D-Gnome 0.9.4-2 requires Theme-D 3.0.4. This release of Theme-D-Gnome may not work with newer Theme-D versions in which case a new version of Theme-D-Gnome shall be released.
  • guile-gnome2 version 2.16.2, 2.16.4, or 2.16.5.
  • GNU make

Downloading the Library

Debian or Ubuntu

If you have installed Theme-D with command apt-get install Theme-D-Gnome with command
	    sudo apt-get install theme-d-gnome
	  
If you have installed Theme-D version 3.0.0 or later follow the instructions in the next paragraph. If you have installed an older version of Theme-D you may upgrade it to 3.0.4 and follow the instructions in the next paragraph.

Other Debian-based systems

Get the Theme-D-Gnome package and Theme-D-Gnome development package and install them with commands
	    sudo dpkg -i theme-d-gnome_0.9.4-2_all.deb
	    sudo dpkg -i theme-d-gnome-dev_0.9.4-2_all.deb
	  

Other systems

Get the library source from theme-d-gnome-0.9.4.tar.xz . See Theme-D-Gnome User Guide for installation instructions.

Source code

Theme-D-Gnome source code can be found at theme-d-gnome-0.9.4.tar.xz . The debianization files can be found at theme-d-gnome_0.9.4-2.debian.tar.xz . The .dsc file can be found here.

Downloading Older Versions

Back to the main page

Last updated: June 21, 2020

Copyright (C) 2020 Tommi Höynälänmaa

tommi.hoynalanmaa@REMOVETHISiki.fi